Visual LAN

A. DASAR-DASAR VLAN

Seperti tampak pada Gambar1, network-network switch layer 2 biasanya dirancang sebagai networknetwork yang flat atau datar, setiap paket broadcast yang ditransmisikan akan terlihat oleh setiap alat di network tidak tergantung apakah alat itu membutuhkan atau tidak. Jika PC 0 mengirimkan sebuah frame maka tersebut akan diforward ke semua end device (PC0-PC5)

Secara defaul, router membolehkan broadcast hanya di dalam network di mana paket broadcast itu berasal, tetapi switch-switch mem-forward paketpaket broadcast ke semua segmen. Alasan mengapa disebut network yang flat adalah karena networknetwork berada dalam satu broadcast domain, jadi bukan karena rancangan datar secara fisik. Jika pada gambar 1 diterapkan sebuah network swithch layer 2 maka frame hanya akan di forward kan ke host tujuan sehingga frame tidak akan terlihat oelh host lain dalam jaringan.

Jadi keuntungan terbesar yang diperoleh dengan memiliki network switch layer 2 adalah ia menciptakan sebuah coallision domain sendiri-sendiri untuk setiap alat yang terhubung ke setiap port pada switch tersebut. Skenario ini membebaskan kita dari keterbatasan jarak Ethernet sehingga sebuah wan yang lebih besar dapat dibuat. Tetapi setiap kemajuan baru biasanya akan diikuti dengan masalah baru juga, semakin besar jumlah user dan alat, semakin banyak broadcasr dan paket yang harus di tangani oleh sebuah switch, dan masalah yang lain nya adalah security atau keamanan. Keamanan menjadi faktor yang sangat penting karena di dalam internetwork switch layer 2, semua user secara default dapat melihat semua alat di network tersebut, dan kita tidak bisa menghentikan alat-alat tersebut untuk melakukan broadcasting atau menghentikan user untuk melakukan respon terhadap broadcast. Jika kondisinya seperti demikian maka pilihan keamanan hanya terrbatas pada menempatkan password pada server dan alat-alat di network.

Tetapi akan berbeda jika kita menciptakan sebuah Virtula LAN (VLAN), banyak masalah yang bisa dipecahkan pada switching layer 2 dengan VLAN. Ada beberapa cara VLAN dalam menyederhanakan management network :

1. Penambahan, perpindahan, dan perubahan network dilakukan dengan mengkonfigurasi sebuah port ke VLAN yang sesuai.

2. Sekelompok user yang memerlukan keamanan yang tinggi dapat ditempatkan pada sebuah VLAN sehingga tidak user di luar VLAN tersebut yang dapat berkomunikasi dengan mereka.

3. Sebagai pengelompokan logikal user berdasarkan fungsi, VLAN dapat dianggap independen dari lokasi fisikal atau geografisnya.

4. VLAN dapat meningkatkan keamanan network

5. VLAN-VLAN meningkatkan jumlah broadcast domain dan pada saat yang sama memperkecil ukurannya sendiri.

B. Mengapa Menggunakan VLAN?

1. Kontrol Terhadap Broadcast

Broadcast terjadi di semua protokol, tetapi seberapa sering terjadinya tergantung pada tiga hal berikut :

◦ Jenis protokol

◦ Aplikasi yang berkerja di internetwork

◦ Bagaimana layanan-layanan network digunakan

Aplikasi-aplikasi pada dewasa ini semakin banyak membutuhkan bandwith, terutama aplikasi-aplikasi multimedia yang menggunakan broadcast dan multicast secara ekstensif. Memastikan agar network disegmentasi atau dipisahkan dengan baik, untuk mengisolasi masalah di satu segmen dan menghindari penyebarannya ke network lain atau internetwork adalah sebuah keharusan. Cara melakukan ini adalah dengan strategi switching dan routing yang baik, yaitu dengan network switch murnidan lingkungan VLAN. Semua peralatan di sebuah VLAN adalah anggota dari broadcast domain yang sama dan menerima semua broadcast. Secara default, broadcast tidak akan dilewatkan pada pada port dari sebuah switch yang bukan merupakan anggota VLAN yang sama.

1.1 Keamanan

Administrator akan dapat memiliki control ternhadap setiap port dan user dengan cara membuat VLAN dan menciptakan banyak kelompok broadcast, dengan demikian user tidak akan bisa lagi dengan leluasa untuk menghubungkan work station mereka ke sembarang port pada swich dan memperoleh akses ke sumber daya network. Vlan juga dapat dibuat sesuai dengan kebutuhan sumber daya nework dari user, switchswitch dapat dikonfigurasi untuk memberikan informasi ke sebuah stasiun managemen network jika ada akses-akses yang tidak diizinkan ke sumber daya network.

1.2 Fleksibilitas dan Skalabilitas

Apakah perbedaan router dengan switch? Secara default switch membagi coallision domain sedangkan router membagi broadcast domain.

memperlihatkan bagaimana sebuah switch-switch yang menerapkan VLAN menghilangkan batasan-batasan fisikal. Gambar diatas menunjukkan bagaimana 4 buah VLAN digunakan untuk menciptakan sebuah broadcast domain untuk setiap departmen dalam perusahaan. Setiap port dari switch kemudian secara administrative ditempatkan sebagai sebuah anggota dari sebuah VLAN. Jika seorang user untuk Marketing (VLAN2) perlu ditambahkan, maka port yang digunakan untuk user tersebut dapat dibuat menjadi anggota VLAN2 tidak bergantung dari lokasi fisikal dari port atau lokasi user baru tersebut. Mengapa VLAN di mulai dengan no 2, nomor ini tidak lah penting tetapi mengapa tidak dimulai dengan VLAN1? Karena VLAN1 adalah sebuah VLAN administratif dan cisco merekomendasikannya untuk tujuan administrative saja. Secara default semua port dalam sebuah switch adalah anggota dari VLAN1 sebelum port tersebut di masukkan menjadi anggota VLAN yang lain, dan VLAN1 ini tidak dapat dihapus ataupun diubah dari switch.

C. CONTOH MENGKONFIGURASI VLAN

subneting tidak dibahas pada contoh ini.

1. konfigurasi pc

2. konfigurasi dasar pada switch 1

Switch>ena

Switch#conf

Configuring from terminal, memory, or network

[terminal]?

Enter configuration commands, one per line. End

with CNTL/Z.

Switch(config)#hostname S1

S1(config)#enable secret class

S1(config)#no ip domain-lookup

S1(config)#line console 0

S1(config-line)#password cisco

S1(config-line)#login

S1(config-line)#exit

S1(config)#line vty 0 15

S1(config-line)#password cisco

S1(config-line)#login

S1(config-line)#exit

S1(config)#ip default-gateway 172.20.29.1

S1(config)#end

%SYS-5-CONFIG_I: Configured from console by

console

S1#copy r

S1#copy running-config s

S1#copy running-config startup-config

Destination filename [startup-config]?

Building configuration…

[OK]

3. configure VTP pada sw 1

S1(config)#vtp mode server

Device mode already VTP SERVER.

S1(config)#vtp domain Lab3

Changing VTP domain name from NULL to Lab3

S1(config)#vtp password cisco

Setting device VLAN database password to cisco

S1(config)#end

%SYS-5-CONFIG_I: Configured from console by

console

S1#copy running-config startup-config

Destination filename [startup-config]?

Building configuration…

[OK]

4. Enable kan port pada s1 dalam acces mode

S1(config)#int fa0/1

S1(config-if)#switchport mode access

S1(config-if)#no shutdown

S1(config-if)#exit

S1(config)#int fa0/2

S1(config-if)#switchport mode access

S1(config-if)#no shutdown

S1(config-if)#exit

S1(config)#int fa0/3

S1(config-if)#switchport mode access

S1(config-if)#no shutdown

S1(config-if)#end

%SYS-5-CONFIG_I: Configured from console by

console

S1#copy running-config startup-config

Destination filename [startup-config]?

Building configuration…

[OK]

5. buat trungking port sw1 pada device Fa0/4

S1(config)#int fa0/4

S1(config-if)#switchport mode trunk

S1(config-if)#switchport trunk native vlan 99

S1(config-if)#end

6. Buat vlan pada vtp server (sw1)

S1(config)#vlan 99

S1(config-vlan)#name Management&Native

S1(config-vlan)#exit

S1(config)#vlan 10

S1(config-vlan)#name Students

S1(config-vlan)#exit

S1(config)#vlan 20

S1(config-vlan)#name Staff

S1(config-vlan)#exit

S1(config)#vlan 30

S1(config-vlan)#name Guest

S1(config-vlan)#exit

S1(config)#end

7. verifikasi vlan yang sudah dibuat

8. masukkan port2 ke dalam vlan

S1(config)#int vlan 99

%LINK-5-CHANGED: Interface Vlan99, changed

state to upS1(config-if)#

S1(config-if)#ip address 172.20.28.2

255.255.255.240

S1(config-if)#exit

S1(config)#int fa0/1

S1(config-if)#switchport access vlan 10

S1(config-if)#exit

S1(config)#int fa0/2

S1(config-if)#switchport access vlan 20

S1(config-if)#exit

S1(config)#int fa0/3

S1(config-if)#switchport access vlan 30

S1(config-if)#end

9. konfigurasi router 1

Router(config)#hostname R1

R1(config)#ena

R1(config)#enable s

R1(config)#enable secret clas

R1(config)#enable secret class

R1(config)#no ip domain-lookup

R1(config)#line console 0

R1(config-line)#password cisco

R1(config-line)#login

R1(config-line)#exit

R1(config)#line vty 0 15

R1(config-line)#password cisco

R1(config-line)#login

R1(config-line)#exit

R1(config)#end

10. konfigurasi trunking interface (sub interface) pada Router 1

R1(config)#int fa0/0

R1(config-if)#no sh

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0,

changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on

Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#int fa0/0.10

R1(config-subif)#encapsulation dot1Q 10

R1(config-subif)#ip ad

R1(config-subif)#ip address 172.20.8.1

255.255.248.0

R1(config-subif)#exit

R1(config)#int fa0/0.20

%LINK-5-CHANGED: Interface

FastEthernet0/0.20, changed state to up

R1(config-subif)#encapsulation d

R1(config-subif)#encapsulation dot1Q 20

R1(config-subif)#ip address 172.20.16.1

255.255.248.0

R1(config-subif)#exit

R1(config)#int fa0/0.30

R1(config-subif)#encapsulation dot1Q 30

R1(config-subif)#ip address 172.20.24.1

255.255.254.0

R1(config-subif)#exit

R1(config)#int fa0/0.99

R1(config-subif)#encapsulation dot1Q 99 native

R1(config-subif)#ip address 172.20.29.1

255.255.255.240

R1(config-subif)#end

R1#copy running-config startup-config

Destination filename [startup-config]?

Building configuration… [OK]

D. APA ITU VLAN

Sebuah Local Area Network (LAN) pada dasarnya diartikan sebagai sebuat network dari kumpulan computer yang berada pada lokasi yang sama. Sebuah LAN diartikan sebagai single broadcast domain, artinya ada sebuah broadcast informasi dari seorang user dalam LAN, broadcast akan diterima oleh setiap user lain dalam LAN tersebut.Broadcast yang keluar dari LAN bisa difilter dengan router. Susunan dari broadcast domain tergantung juga dari jenis koneksi fisik perangkat networknya. Virtual Local Area Network (VLAN) dikembangkan sebagai pilihan alternatif untuk mengurangi broadcast traffic.

Sebuah Virtual LAN merupakan fungsi logik dari sebuah switch. Fungsi logik ini mampu membagi jaringan LAN ke dalam beberapa jaringan virtual. Jaringan virtual ini tersambung ke dalam perangkat fisik yang sama. Implementasi VLAN dalam jaringan memudahkan seorang administrator dalam membagi secara logik group-group workstation secara fungsional dan tidak dibatasi oleh lokasi.

Dalam tradisioanl LAN, workstation masing-masing terhubung dengan workstation yang lain dalam sebuah hub. Perangkat ini akan menyebarkan semua lalu lintas data di seluruh network. Jika ada dua user yang mencoba mengirim informasi pada waktu yang sama, sebuah tabrakan (collision) akan terjadi dan semua pengiriman data akan hilang. Jika tabrakan (collision) telah terjadi, pengiriman data akan dilanjutkan disebar di seluruh network oleh hub. Informasi data asal akan terus mengirim sampai dengan collision hilang. Dengan demikian akan banyak membuang waktu dan resource (sumber daya).

Untuk mengatasi collision di sebuah network, maka digunakanlah sebuah bridge atau sebuah switch. Perangkat ini tidak akan mem-forward collision, tapi bisa melewatkan broadcast (ke setiap user di network) dan multicast. Dan sebuah router digunakan untuk mencegah broadcast dan multicast dari lalulintas data network.

E. UNTUK APA VLAN

Menurut IEEE standard 802.1Q, Virtual LANs menawarkan sebuah metode untuk membagi satu fisik network ke banyak broadcast domains. dalam network besar, broadcast domain ini biasanya sama dengan batas IP subnet, yang masing-masing subnet mempunyai satu VLAN.

Sebuah VLAN membolehkan banyak Virtual LANs berdampingan dalam sebuah fisik LAN (switch). Artinya jika ada dua mesin yang terhubung dalam switch yang sama tidak dapat mengirim Ethernet frames ke mesin lain meskipun dalam satu kabel yang sama. Jika dibutuhkan untuk komunikasi, maka sebuah router harus ditempatkan di antara dua VLAN tersebut untuk memforward paket, seperti jika ada dua LAN yang secara fisik terpisah.

Untuk mengenali traffic dari VLAN yang berbeda, 802.1Q standard mendefinisikan sebuah metode yang disebut VLAN TAGGING. dengan tagging, switches memasukkan 4-bit VLAN tag ke dalam header dari masing-masing frame. sebuah tag mengandung 12-bit. VLAN ID. pengenal frame anggota VLAN.

VLAN itu adalah sebuah broadcast domain. Pada sebuah jaringan yang dapat saling komunikasi antar node tanpa melalui router, itu dapat disebut berada pada broadcast domain yang sama (atau vlan yang sama). Misalnya terhubung pada switch yang sama dan dapat saling komunikasi/share/ping dll.

Kata VLAN (Virtual Lan), dimana ada kata virtual pada vlan mengandung pengertian, bahwa jaringan yang berada pada broadcast domain yang sama tersebut dapat berada pada jaringan fisik atau switch yang berbeda (atau lokasi) yang berbeda). Misalnya di JTE

VLAN (antar group) itu apakah komunikasinya hanya dapat dilakukan dengan Multilayer Switch seprti di JTE? apakah Switch yang sudah support VLAN ngga bisa terjadi komunikasi antar VLAN?

Untuk menghubungkan antar VLAN, harus menggunakan device yang support di layer 3 OSI, spt Router, Multilayer Switch, atau bahkan PC router PC/Router yang dimaksud tidak harus menggunakan banyak interface (kartu jaringan/Module FastEthernet), tapi bisa menggunakan model “Router on a stick”

Jika menggunakan PC Router di Linux/BSD, perhatikan driver/module dan chipset yang digunakan oleh FastEthernet/GigabitEthernet yang ingin digunakan, karena tidak semua support VLAN. Umumnya GigabitEthernet sudah support VLAN/Trunking pada BSD/Linux.

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

%d blogger menyukai ini: